1

Topic: Upgrade R6 from 6.29 to 6.30

Since purchasing our R6 licence I assume we still post problems on this Forum.

I want to upgrade from 6.29 to 6.30. I have downloaded the 6.30 zipped file from the website and extracted the files to a new folder. Clicking on the Upgrade exe file brings up a message "Recorder is not correctly installed on this machine. Upgrade cannot proceed". Can anyone advise what checks our IT can carry out to resolve the problem? Recorder sits in its own server and the networked copy of R6 is run from a laptop. We are getting this error message when running either from my laptop or directly from the R6 server. We are currently on 6.29.0.290, dictionary 4K.

Bob Marsh
Doncaster LRC

Bob Marsh
Doncaster LRC
Coleoptera recorder for YNU

2

Re: Upgrade R6 from 6.29 to 6.30

For network installations the upgrade needs to be run on a  workstation  (the laptop)  which has a working copy of R6 - you will need Admin rights on  the Server and workstation and also for SQL server. This error only occurs when the upgrade fails to read the registry to establish where  the files are and the database name/location. Running the RecorderUpgrade as Admin might solve the problem. Right click on RecorderUpgrade and choose run as Administrator.

Mike Weideli
Littlefield Consultancy - IT Consultants

3

Re: Upgrade R6 from 6.29 to 6.30

Thanks for the speedy response Mike - I'll take that back to our IT man and see what happens - I'll get back to you with progress

Bob
Doncaster LRC

Bob Marsh
Doncaster LRC
Coleoptera recorder for YNU

4

Re: Upgrade R6 from 6.29 to 6.30

Our IT have upgraded to 6.30 and rebuilt indexes. What about dictionary. Do we now select Update Dictionary in Tools>Database Tools ? Will this upgrade to 4Q from the present 4K?

Bob Marsh
Doncaster LRC
Coleoptera recorder for YNU

5

Re: Upgrade R6 from 6.29 to 6.30

Does the dictionary have to be run at the same time as the software upgrade or can it be done later??

Bob Marsh
Doncaster LRC
Coleoptera recorder for YNU

6

Re: Upgrade R6 from 6.29 to 6.30

Hi Mike - our IT have upgraded to 6.30 from 6.29 and rebuilt indexes. Precisely when do they carry out the dictionary update from the present 4K to 4Q. Has this to be done at the same time as the main upgrade or can it be done later??

Bob Marsh
Doncaster LRC
Coleoptera recorder for YNU

7

Re: Upgrade R6 from 6.29 to 6.30

Help required.....

Got a problem running the Dictionary update after updating to 6.30 (network installation)

Tools>database Tools>Update Dictionary

I then get window….
Dictionary Update. The last update processed was 00004K.sql. Select OK to proceed > OK

Then got Dict update window with the following info
File location   \\dmbcrecorder6l\RecorderAppFiles\User Files\
Current Dictionary 4K. Update file 000004L.sql
Dictionary Status original
Block size 50. Licence key [entered]
    OK

Then got “The required file is not in the specified folder” > OK

Where will I find the required file? Is it called "Dictionary Updater5" in the 6.30 upgrade zip??

I'm a bit nonplussed - any help more than welcome

Bob
Doncaster LRC

Bob Marsh
Doncaster LRC
Coleoptera recorder for YNU

8

Re: Upgrade R6 from 6.29 to 6.30

After much head-scratching, sweating and twitching now looks if we have been successful in upgrading to 6.30 and Dict 4Q

Bob
DLRC

Bob Marsh
Doncaster LRC
Coleoptera recorder for YNU