Topic: Recorder 3 "fatal error"

I have been happily running Recorder 3.4.3 (AREV v3.12) in DOSBox for some while. After processing one set of new record lists I received an error when I tried to update the indexes. I have been unable to rebuild the indexes for the same error which says "Fatal Error Readnexting in table !RECORDS" - see attached file for a screenshot.

Except that some background processing encounters the same error and chucks me out to the main screen whenever I pause in doing things, I can still enter records, but can't add them to the index.

I wondered about deleting REV20044.OV or replacing it with an older version, but I have no idea what this will do to my data. Help!


paul smith

Post's attachments

recorder 3.4 error.jpg 170.26 kb, file has never been downloaded. 

You don't have the permssions to download the attachments of this post.


Re: Recorder 3 "fatal error"

I managed to fix this by copying an old REV20044.OV file (from an earlier backup), then rebuilding all the indexes in the Records table. (I actually did it in a separate directory and then copied the REV20044.OV and REV20044.LK files back to the original location). I tried running recorder without the 20044.OV file, in the hope that it could be rebuilt, but that didn't show any records.