1

Topic: User UNable to Load Map Files

HI All

I have had a report as detailed below concerning ESRI MapFiles not loading. Is anyone else experiencing this issue ?. I can't load the files into R6.  Has anyone with GIS experience any idea what could eb causing the problem ? 

-----
   
We have recently started to get this error message when trying to import a shapefile on the Data Searches map in R6 . The shapefiles open just fine both in ArcGIS Pro and QGIS.

We don’t get this error with all shapefiles and I can’t figure out what could be causing this. I tried the following:
- I used two different software to create shapefiles, ArcGIS Pro and QGIS
- I also tried to save the shapefiles in different locations

Post's attachments

Shapefiles.zip 12.82 kb, 1 downloads since 2021-02-26 

You don't have the permssions to download the attachments of this post.
Mike Weideli
Littlefield Consultancy - IT Consultants

2

Re: User UNable to Load Map Files

(I assume Test.shp is the problem as this fails to load on my Recorder; this might all be a red herring)

Converting it to MapInfo TAB and then back to ESRI Shapefile allows me to load it into Recorder. It appears to be a problem with the SHX; or at least replacing the "bad" SHX with the copy created by MapInfo allows it to be loaded into Recorder.

QGIS seems to create the same SHX as supplied, but for some reason MapInfo (or rather FME) creates a different one that Recorder is happy with.

Charlie Barnes
Information Officer
Greater Lincolnshire Nature Partnership

3

Re: User UNable to Load Map Files

Hi
Many thanks. I can't load either of the two files into R6.

Mike Weideli
Littlefield Consultancy - IT Consultants

4

Re: User UNable to Load Map Files

For the record this seems to be a way forward. Try loading the file into the https://mapshaper.org/ 

You can drag the  in the zip file containing the shp,shx  and db file into the bottom part of the Window (Quick Import). Then click on Export. Leave the defaults and save the file.  In my system the resulting file when unzipped can be loaded into recorder 6.

As far as I can tell the site is safe (Norton Websafe), but you must  make up your own mind about this.

I am not suggesting this as a long term solution, but if it works it will help until we can find out what the underlying problem is. It looks like it can convert multiple files at one time.

in the Test file there is a slight difference in the attributes between the file which loads and the one that doesn’t. Viewing the attributes in mapshaper.org the file which doesn’t load has a red * next to ‘Complex’. Perhaps this suggest something wrong with this attribute ? However, I can't see any differences with the other file.

Mike Weideli
Littlefield Consultancy - IT Consultants