1

Topic: Recorder 6 Workstation Install

Hello folks, we are in the process of replacing our IT kit - servers and pcs. I've got clean R6.30 installed on a new server and I can connect to the server and all our lovely data by editing the registry on our existing pcs. However I'm unable to perform a successful new workstation install. I'm attempting to install it in to a windows server 2016 standard edition vm. When I run the WorkstationSetup.exe from the mapped drive in our new vm it seems to install, but when it completes and I attempt to run it I get the following error:

EOleException: Unable to load communication module. Driver has not been correctly installed

The WorkstationSetup.exe file appears to be version 6.23.2.279 and the R6 Splash screen still has the JNCC logo. Is there a more recent version of the file?

Thanks

Ian

2

Re: Recorder 6 Workstation Install

Hi

I am not sure what is causing this problem, but it isn't anything to do with the version of the workstation install - it hasn't been necessary to update it.  It looks like one of the drivers hasn't installed on the workstation, which could be because the user doing the install didn't have enough permission, or because a virus checker or similar is preventing the installation. If neither of these seems likely I can dig a bit deeper.

Mike Weideli
Littlefield Consultancy - IT Consultants

3

Re: Recorder 6 Workstation Install

Thanks Mike, I've managed to install QGIS, Notepad++, Visual Studio 2019.... so doesn't seem likely to be a permissions issue. There is only Windows Defender installed at the moment which isn't reporting any issues.

Ian

4

Re: Recorder 6 Workstation Install

Hi

I will investigate and see what I can find.

Mike Weideli
Littlefield Consultancy - IT Consultants

5

Re: Recorder 6 Workstation Install

Thanks Mike!

6

Re: Recorder 6 Workstation Install

Hi

Investigating this on the web, it looks like an ODBC connection issue. Can you try setting up an ODBC link through control panel to the R6 SQL database.  This may  give more indication as to the reason for the problem.

Mike Weideli
Littlefield Consultancy - IT Consultants

7 (edited by ian 05-03-2020 16:32:25)

Re: Recorder 6 Workstation Install

Thanks Mike, I've created an ODBC connection - it all works fine. I've just investigated the workstation install log on the new vm and compared it to the one on my existing system. The new install log is missing the following:

C:\Windows\System32\adortl70.bpl
C:\Windows\System32\bdertl70.bpl
C:\Windows\System32\dbrtl70.bpl
C:\Windows\System32\dsnap70.bpl
C:\Windows\System32\rtl70.bpl
C:\Windows\System32\vcl70.bpl
C:\Windows\System32\vclactnband70.bpl
C:\Windows\System32\vcldb70.bpl
C:\Windows\System32\vcljpg70.bpl
C:\Windows\System32\vclx70.bpl

I'm a member of the local admin group on the vm and a can paste a txt file in to the folder if I give it administrator permission. I've tried right clicking on WorkstationSetup.exe and running as administrator but the install log still doesn't include the files listed above.

edit:
For info the files are present on my existing workstation in the Windows\SysWOW64 but not in the new install SysWOW64 folder - I can paste in to this folder too

Ian

8

Re: Recorder 6 Workstation Install

Hi

They look like they are files in the install System folder in BorlandPackages.zip.  They are in all versions of R6 and don't seem to have changed since 2004. They should end up in the 'Recorder 6/Workstation  SetUp' folder (still zipped). They are there in my network install of 6:30.  If they are not there for you  try copying the zip file in from the install.

Mike

Mike Weideli
Littlefield Consultancy - IT Consultants

9

Re: Recorder 6 Workstation Install

Thanks Mike, they are in my recorder 6/workstation setup folder zipped as you describe. WorkstationSetup.exe sits in the recorder 6 folder, but doesn't seem to pick the files up when I install. Any suggestions?

Ian

10

Re: Recorder 6 Workstation Install

Hi

I have asked John van-Breda for his advice on this.On a 64 bit machine they seem to be going into C:Windows\SysWOW64\  If they are there then  they may not be the cause of the problem.

Mike Weideli
Littlefield Consultancy - IT Consultants

11

Re: Recorder 6 Workstation Install

Thanks Mike, I've done some more digging on this over the weekend - I successfully installed R6 workstation on the server (in a VM) that hosts the R6 database, but have had no luck with the VM that is supposed to host all our apps.

12

Re: Recorder 6 Workstation Install

Hi Mike any news from John on this?

Thanks

Ian