1 (edited by namwebs 18-02-2020 20:14:58)

Topic: Verification 5 - help please!

Hi,

I am having trouble with Verification 5 since my whole system was updated last week. I have read this post: https://forums.nbn.org.uk/viewtopic.php?id=6667 and learned from that that it is now necessary to specify a Master Species checklist in the iform settings, which I have done. After that, any verification page just gives the same error reported in post 6667, to which no solution was given.

How do I get verification working again? Everything is up to date, but is there something else I need to do? I'm testing with default settings for everything including reports (Explore occurrences (standard filters); Explore occurrences map (standard filters); Explore occurrences map (standard filters, low resolution); Record data for verification; Record attributes for verification).

I also tried increasing this, in the indicia.php file as suggested but it didn't help: $config['nonce_life'] = 72000;

Both the modules the report needs are also installed and enabled: "Requires the Easy Login module and Indicia AJAX Proxy module to both be enabled."

The error is:

Page load failed: Invalid response received from Indicia Warehouse. Array ( [result] => 1 [output] => Unrecognised entity taxon_designation [request] => index.php/services/data/taxon_designation?mode=json&orderby=title&auth_token=8732b8d4f92a32b5e82a971646e52c9d725dc698&nonce=0de44dc32f76141a30f42d0cf207f6c2ea606dcb )

2

Re: Verification 5 - help please!

Hi Alice,
On your warehouse, application/config/config.php file, add the taxon_designations module to the list of installed modules. Then visit index.php/home/upgrade on your warehouse to install the additional tables.
Best wishes
John

John van Breda
Biodiverse IT

3

Re: Verification 5 - help please!

Hi John,

THANK YOU. That works.

One side effect of its requirement that there is a master list set in the iform settings is that the pages using the Reporting > Report Selector don't show the full drop-down list all taxa any more, just "<any goup>" and the one in the master list. There doesn't seem to be an option to amend this in the UI - do I just need to edit those reports?