1 (edited by Lindsay_FifeNature 16-12-2019 12:58:05)

Topic: Added designation - not being included in reports

Today I created a new designation, following all the steps at http://archive.jncc.gov.uk/page-4974 which I've done successfully before.

It seemed to have worked - when I run Sy05 - Taxon Designations Available for sets, it's listed, with the right number of species against it; it's listed in the table returned by the 'View designation details' report; when I use ‘Find designations for <taxon>', the new designation is returned in the results; and, if I browse to species  new designation was applied to in the Taxon Dictionary Browser, it's included in the table under Statuses in the panel to the right of the hierarchy.

However, I can't get the new status to come out in reports.  In the report wizard, I've tried checking boxes for all the options under Designation Sets> All Designations as well as all those under the Set the new designation comes under, but the new designation isn't coming out anywhere.

Has anyone experienced this or does anyone have any suggestions as to what might be happening and how I can rectify it?

Thanks in advance for any help.
Linds

Lindsay Bamforth
Fife Nature Records Centre,
Information Officer

2

Re: Added designation - not being included in reports

Hi

I am not sure about this. I will have to set up a designation and track through what is happening, so it may be a few days before I can look at it.

Mike Weideli
Littlefield Consultancy - IT Consultants

3

Re: Added designation - not being included in reports

I have custom designations and I have had problems with them through the reporting wizard since upgrading to 6.29. For me I can get outputs for the designations but they no longer save in report wizard layouts, meaning I have to manually select them each time to access them. Unlike yours Lindsay these are not new designations (they were created ages ago), but the issue about them not saving in wizard layouts has just started since the last upgrade. I have several layouts where these were included previously and they no longer appear when the layout is selected.

Mark

Mark Pollitt
SWSEIC (formerly DGERC)

4

Re: Added designation - not being included in reports

Hi
I will investigate asap.

Mike Weideli
Littlefield Consultancy - IT Consultants

5

Re: Added designation - not being included in reports

MikeWeideli wrote:

Hi

I am not sure about this. I will have to set up a designation and track through what is happening, so it may be a few days before I can look at it.

Thanks Mike.  Just let me know if there's anything I can run and send over to you that would help as you look into it.

Linds

Lindsay Bamforth
Fife Nature Records Centre,
Information Officer

6

Re: Added designation - not being included in reports

Hi Lindsay

It works OK for me with a simple test of a new designation type and new designation. You don't  specifically say you rebuilt the Taxon Designation Index before creating the new set. Could you confirm that you did do this, before I look further.

Mike Weideli
Littlefield Consultancy - IT Consultants

7

Re: Added designation - not being included in reports

Hi Mark

Could you send me the Wizard file for one that doesn't work. They should  be in the R6 User File folder  under Reports with an extension .wzd

Mike Weideli
Littlefield Consultancy - IT Consultants

8

Re: Added designation - not being included in reports

MikeWeideli wrote:

Hi Lindsay

It works OK for me with a simple test of a new designation type and new designation. You don't  specifically say you rebuilt the Taxon Designation Index before creating the new set. Could you confirm that you did do this, before I look further.

Hi Mike,

I did rebuild the Taxon Designation Index.

Thanks,
Linds

Lindsay Bamforth
Fife Nature Records Centre,
Information Officer

9

Re: Added designation - not being included in reports

Hi Lindsay

I will do you a report which will show what is is in all the tables related to the new designation set you have created. Hopefully, this will show why it isn't working.

Mike Weideli
Littlefield Consultancy - IT Consultants

10

Re: Added designation - not being included in reports

Thanks for your help Mike - it will be really really useful to get this resolved.


Linds

Lindsay Bamforth
Fife Nature Records Centre,
Information Officer

11

Re: Added designation - not being included in reports

Sending wizard file through Mike...

Mark Pollitt
SWSEIC (formerly DGERC)

12

Re: Added designation - not being included in reports

Hi Lindsay

Try the attached report. (Menus LC). If it produces a result and shows the new designation you have set up then please send to me as an Excel file. Otherwise let me me know.

Mike Weideli
Littlefield Consultancy - IT Consultants

13

Re: Added designation - not being included in reports

Hi Mark

The report shows one of the designations coming out first (position 0), but most of them coming out at the end.  Is this what you are seeing in the results or are some column missing completely ?

What strange is that no work was done on this area in 6.29 or in fact for a long time, although with R6 some apparently unrelated change can have a knock on effect.

Post's attachments

LCUserDefinedDesignationCheck1.xml 1.48 kb, 1 downloads since 2019-12-09 

You don't have the permssions to download the attachments of this post.
Mike Weideli
Littlefield Consultancy - IT Consultants

14

Re: Added designation - not being included in reports

MikeWeideli wrote:

Hi Lindsay

Try the attached report. (Menus LC). If it produces a result and shows the new designation you have set up then please send to me as an Excel file. Otherwise let me me know.

Hi Mike,

Sorry, I can't see an attached file...

Thanks,
Linds

Lindsay Bamforth
Fife Nature Records Centre,
Information Officer

15

Re: Added designation - not being included in reports

Sorry. It was there at one time. Back now.

Mike Weideli
Littlefield Consultancy - IT Consultants

16

Re: Added designation - not being included in reports

I'll email over the export.  It shows ones I've set up in the past, but not new ones.

Thanks,
Linds

Lindsay Bamforth
Fife Nature Records Centre,
Information Officer

17

Re: Added designation - not being included in reports

Hi

Some part of the new set up must be missing. I will adapt the report to identify what it is.

Mike Weideli
Littlefield Consultancy - IT Consultants

18

Re: Added designation - not being included in reports

Hi

This looks like it is the Taxon_Designation_Set_Item table. Please can you try the attached report which will confirm this. Your new set should show, perhaps without TDSI details.

Post's attachments

LCUserDefinedDesignationCheck2.xml 836 b, 1 downloads since 2019-12-13 

You don't have the permssions to download the attachments of this post.
Mike Weideli
Littlefield Consultancy - IT Consultants

19

Re: Added designation - not being included in reports

Hi Mike,

Thanks for looking at this.  I just ran the report and the new ones still aren't coming through.  I'll email you the export.

Linds

Lindsay Bamforth
Fife Nature Records Centre,
Information Officer

20

Re: Added designation - not being included in reports

Hi

This makes it look like the set isn't there.  Can you try running Batch Update JNCCDes1 again after checking that  the csv file is there and populated with the correct headings. (see description on JNCCDes1) . If the last report still doesn't show the set, please let me have a copy of the csv file. S
-

Mike Weideli
Littlefield Consultancy - IT Consultants

21

Re: Added designation - not being included in reports

That looks to have sorted it - thanks Mike!

Linds

Lindsay Bamforth
Fife Nature Records Centre,
Information Officer