1

Topic: MR won't let me enter new samples or species lists

I have spent two days wrangling with Marine Recorder with the help of JNCC staff, with a stream of errors on my Marine Recorder v 5.41 on Windows 7 computer that none of us can resolve.

The latest error is most worrying:
"Debug Error 3022 - the changes you requested to the table were not successful because they would create duplicate values int he index, primary key or relationship. Change the data in the field or fields that contain duplicate data, remove the index, or redefine the index to permit duplicate entries and try again."

There are no obvious duplicate keys when I run a validation matrix. I am now worried that somehow this could be a warning that it's been edited in someone else's Site ID, although surely that should create new keys not old ones.

We have tried uninstalling, complete computer wipe of all MR files, reinstalling, tried three backup files from this year.

Any ideas gratefully received. In 10 years of MR experience this is the most frustrating sequence of errors.

2 (edited by sally.stewart-moore 21-12-2017 13:14:12)

Re: MR won't let me enter new samples or species lists

Hi Liz,
That is so strange as I have been getting the identical error message this week! I put mine down to merging datasets.

I merged 2 datasets together and all seemed to be working fine and I was able to continue adding data, however I then noticed that a couple of surveys and events were missing from the new merged Master .mdb file. I ran another merge for these surveys alone, choosing to over write them and it seemed to work, appearing in the Master .mdb. However when it came to uploading new data I got the 3022 error.

I didn't have time to wait and so have reverted back to my last .mdb backup before the original merge and have just re-entered any data I had lost. However it means I still have missing surveys and events that I need to merge in. I am afraid to do another merge in case the same happens again.

Had you recently run a merge? If so  then try reverting to a previous .mdb backup.

Anyone got any suggestions for why this happened and how I can avoid it happening again next time I need to merge datasets from different users together? Do they need to be merged into a blank .mdb?

Any help would me much appreciated!