Topic: V1.0.8.4 Not Available

I just downloaded the cleaner from;

http://www.nbn.org.uk/Tools-Resources/R … eaner.aspx

However this is  V1.0.8.3 not V1.0.8.4 as the text suggests. Also the software does not update itself and neither does the dictionary.

The first 3 times I tried it failed to connect to the remote server. The next 2 times it says 'Connecting to Remote Server' but does nothing and I cancel after a 2 or 3 minutes.

When I tried using the cleaner I got a message about failing to update the dictionary and to carry on as not essential.

While I'm happy to accept that some or all of the problems might be my circumstance [except the version] I thought it might be worth pointing out just in case.

Data Manger
Somerset Environmental Records Centre


Re: V1.0.8.4 Not Available

Have you tried running it as Administrator? I had a similar problem a few weeks ago and that solved it for me.

Janet Simkin
British Lichen Society


Re: V1.0.8.4 Not Available

Thanks Janet but no joy.

Data Manger
Somerset Environmental Records Centre


Re: V1.0.8.4 Not Available

Hello Tony

The download version is Clicking on the software updates link in the application should update it to V1.0.8.5. These were minor changes to the software. The update mainly updates the species dictionary to keep it in line with the UK Species Inventory.

When update is not working its usually due to access to the require files being blocked eg by a firewall. The NBN Recorder Cleaner requires access to -
1. Initial check to see if there is internet access using www.google.com
2. Checks software and species dictionary are up to date -http://data.nbn.org.uk/recordcleaner/application
3. Checks verification rules - http://data.nbn.org.uk/recordcleaner/rules/servers.txt
It also requires permission to download these rules and species dictionary file onto the user’s local machine which, as Janet says, on Windows 7 /8 machine requires the NBN Record Cleaner to be run as an administrator.

Best wishes

NBN Technical Liaison Officer


Re: V1.0.8.4 Not Available

I'm having troubles with the updates. Having done a fresh download and install (as an administrator) I found I got (not as http://nbn.org.uk/Tools-Resources/Recor … eaner.aspx says I will get if I do a fresh install).

The cleaner then does connect to the internet and says "software updates available" and gives a link, but clicking on it just gives a pop-up window saying:
Updater in Progress
Connecting to Remote Server
  Please ensure that your internet connection is active
    NBN Record Cleaner tool update site
     This site provides automatic updates to the application itself and to core lookup files.

Nothing else happens. I am running it as an Administrator (otherwise it doesn't find that updates are available).

I'm trying to resolve Unknown TVK issues for things that are in Recorder's dictionary (e.g. NHMSYS0021002960, Stonechat, created by Chris Raper on 21/11/2013). I'm assuming an update will fix these?

I'm on a 64-bit windows 7 machine.

Can anyone suggest anything please?

Thanks, Keith


Re: V1.0.8.4 Not Available

P.S. Having found that the pop-up window then stopped popping-up I decided to reboot my computer.

When starting record cleaner as administrator again following the reboot the update worked perfectly and my Unknown TVK issues went away!

So if anyone else has similar problems, try a computer reboot...!