1

Topic: Access request failure

I've tried a number of times to submit an access request for all data overlapping or within the NEYEDC LRC boundary. The page title changes to Conditions and the text says "Submitting request... " with a link to "Return to my account" but nothing happens and there are no pending access requests under my user account. I've left this for over 10 minutes to see if the "Submitting request..." page refreshes but it doesn't appear to.

Can someone let me know what's meant to happen and if there is some restriction to apply another filter which I'm not currently meeting?

Thanks. Dan

2

Re: Access request failure

Hi Dan,

I don't know if this is the problem you may be facing, but the Gateway has limits on the amount of data that can be requested/size of boundary used. It's one of the main stumbling blocks we have here in getting Gateway data used by the Local Authorities (they want all available information!) and in large SLAs.

On the old version there were checks in place, or at least the max size was documented somewhere. I am not sure how this is handled in the new Gateway.

For a previous piece of marine work i ended up breaking the boundary down into small portions then de-duplicating data once pulled back but that was for marine queries where there is much less data. I certainly wouldn't suggest doing it for a large terrestrial boundary.

LERC Officer
Merseyside BioBank - Local Environmental Records Centre for North Merseyside
www.MerseysideBioBank.org.uk

3

Re: Access request failure

I don't know if this is related, but I can't grant access requests.  When I try, I just get an error message saying e.g. 'Problem with request ID:26493'.  I first noticed this a couple of weeks ago - I thought it was just a temporary glitch, but it's still not working

Ellie

Eleanor Knott
Devon Biodiversity Records Centre

4 (edited by LBacon 28-05-2014 15:33:38)

Re: Access request failure

Hi Ellie - I posted a similar phenomenon a couple of weeks ago here:

http://forums.nbn.org.uk/viewtopic.php?id=5440

the gateway team seemed to think it was a glitch!

As I have not had any requests to grant or otherwise since I do not know if its still happening

Louise, CPERC

5

Re: Access request failure

Hi Both,

Quick note to say i was getting a similar glitch preventing me from granting access just yesterday. In the end it worked when i removed the year constraint i had applied to the grant. Fortunately this for a non-sensitive species so i don't have a problem leaving the access open ended.

If i have time i'll chase this up with the team, but i figure they're a bit over burdened at the moment as it is.

LERC Officer
Merseyside BioBank - Local Environmental Records Centre for North Merseyside
www.MerseysideBioBank.org.uk

6

Re: Access request failure

Hi, I have released a fix for this issue, you should now be able to correctly grant access requests with an end date, the issue was with adding an end date when there wasn't one already through the grant dialog, which was causing an issue with an audit trail mechanism we have running on the back end.

If anyone still is having issues please contact us again with further details of the issue,

Thanks,
Matt

Matt Debont
Application Developer
Joint Nature Conservation Committee, Monkstone House, City Road, Peterborough PE1 1JY, UK

7

Re: Access request failure

Thanks Matt.

LERC Officer
Merseyside BioBank - Local Environmental Records Centre for North Merseyside
www.MerseysideBioBank.org.uk