Topic: Marine Wizard Installation

I am testing an installation of the Marine Reporting Wizard on a Windows 7 laptop (32 bit).  When I try and run the "MRReportWizard410" setup application it gives an error as follows;
"The file "C:\\WINDOWS\system32\oleaut32.dll" could not be opened.  Please check that your disk is not full and that you have access to the destination directory"

I am running the setup using Administrator privilages so I don't think that would be the issue.

Any ideas what this issue may be?

Many thanks



Re: Marine Wizard Installation

Hi Stuart,

likely to be specific to your pc and probably to do with antivirus programs. try installing the wizard before you put any Antivirus program on the PC. Pat Kitchener (NRW) had a similar issue recently - you may benefit from a chat.



Re: Marine Wizard Installation

I tried this but still having the problem - this is on the same laptop that Pat was working on last week.  He managed to get the installation to run in the end but the report wizard module would not open within the report dataabase tool.

I am now trying again - have uninstalled and deleted all Marine Wizard files and remove anti virus but still no joy in running the installation.  Pat does not know what he did differently.

Anybody else come across this issue - is it just related to Windows 7?


Re: Marine Wizard Installation

I have managed to resolve this but through a convoluted route.

I had to change each of the dll's that the install updates to be owned by "Administrators" rather than "TrustedInstallers", which it is automatically set to.  This then allows administrators to amend the permissions on the files to "write" and "modify".

I think this is a specific change in the Windows 7 Security profile compared to previous versions of Windows - this will need to be taken into account when Marine Wizard is developed this year.



Re: Marine Wizard Installation

Another issue i have reached with this installation of Marine Wizard in Windows 7 is that the integration with MapInfo does not work at all - I have checked the INI files for both ReportWizardModule and ReportDatabase and they are the same as for my Win XP installation.  However, the software does not appear to even attempt to link with MapInfo (i.e. no pop up asking if you want to open GIS.)  Has anybody else come across this (even if you use ARC GIS instead?)