Topic: Error when Importing data

Hello All,

I'm new to Recorder, and when I tried to import data for the first time (via Excel spreadsheet), I got this error message (full error report attached). Is anyone able to offer any advice?

date/time         : 2022-10-10, 10:00:28, 331ms
computer name     : HQ34-TERMINAL
wts client name   : HQ-CPD-WS116
user name         : charlie.davis
registered owner  : Windows User
operating system  : Windows 2008 R2 x64 Service Pack 1 build 7601
system language   : English
system up time    : 199 days 20 hours
program up time   : 35 minutes 58 seconds
processor         : Intel(R) Xeon(R) Gold 5118 CPU @ 2.30GHz
physical memory   : 483/2047 MB (free/total)
free disk space   : (I:) 496.49 GB (R:) 28.94 GB
display mode      : 1600x900, 16 bit
process id        : $478
allocated memory  : 59.88 MB
command line      : RecorderApp.exe /65608
executable        : RecorderApp.exe
exec. date/time   : 2017-12-14 22:09
version           :
compiled with     : Delphi 7
madExcept version : 3.0n
callstack crc     : $4fa68a4c, $649ba50e, $649ba50e
exception number  : 2
exception class   : EDBMergerError
exception message : Error occurred transferring records for SQLSERVER_SURVEY_EVENT into the main database: Error occurred transferring records for SQLSERVER_SURVEY_EVENT into the main database: ODBC--insert on a linked table 'SQLSERVER_SURVEY_EVENT' failed.

Thank you,


Re: Error when Importing data

Hi Charlie

Sorry, no simple solution from me as this sort of error has come up before (but often for different database tables) but there doesn't seem to be an obvious solution.

There are a few things you could check/try to help track down the cause (in the absence of Mike W or anyone else with a better idea than me):

1. Try running the update Last Key addin (under Tools -> Update Last Key).
2. Try adding an survey event, sample and observation manually (just to check your permissions).
3. Try importing a much smaller file (to check if it's a permissions or data issue).


Andy Foy
Systems Manager
Greenspace Information for Greater London (GiGL) CIC

3 (edited by charlie.davis 11-10-2022 15:08:22)

Re: Error when Importing data

Hi Andy,

Thank you for your suggestions. I've run the Last Key addin and attempted to import a smaller file and still got the same error message. I seem to be able to add surveys/sampling events/observations etc.

Update: it seemed to be a permissions issue as I had them altered and managed to import.

Thank you very much for all your help,