1

Topic: Recorder Login

I have just moved my copy of Recorder from SQL Server Express 2012 to Version 2017

If I run Recorder physically on the Server, it works fine, but I cannot get it to run from a workstation (I have edited the Server setting in the Registry) but I get the following error:

An error occurred whilst starting the application. EOleException: Login failed for user 'NBNUser'

I'm guessing there is a setting in SQL Server I've missed, can anyone tell me what I need to change please

Craig

Craig Slawson
Staffordshire Ecological Record

2

Re: Recorder Login

Hi

The connection problem may be because TCP IP is not enabled by default with SQL Server 2017.     

Open SQL Server Configuration Manager.
    Expand “SQL Server Network Configuration” and click on “Protocols for MSSQLSERVER”
    Right click on “TCP/IP” and choose “Enable”
    Click “OK” on the Warning that the service will have to be restarted.

You might have trouble finding Configuration Manager if it isn't listed in the program menu. In which case try searching Windows help for Computer Management. Configuration Manager can then be found under Services and Applications. TCP/IP, Shared Memory and Named Pipes should be enabled.

Mike Weideli
Littlefield Consultancy - IT Consultants

3

Re: Recorder Login

Sorry Mike,

Not that, I'd already enabled all three options

Craig

Craig Slawson
Staffordshire Ecological Record

4

Re: Recorder Login

Mike,

According to the SQL Server Log, the password is incorrect, but I can log on to the Database via Management Studio and the 'sa' password is fine then!

I have just switched back to the v2012 and can log in with no problems

Craig

Craig Slawson
Staffordshire Ecological Record

5

Re: Recorder Login

Mike,

I've checked the settings of the two instances and the only obvious difference I can find is that the new copy the Login NBNUser is not mapped to the NBNData, but Management Studio throws an error (see below) when I try to9 change the setting for the Login

Craig

TITLE: Microsoft SQL Server Management Studio
------------------------------

Create failed for User 'NBNUser'.  (Microsoft.SqlServer.Smo)

For help, click: https://go.microsoft.com/fwlink?ProdNam … nkId=20476

------------------------------
ADDITIONAL INFORMATION:

An exception occurred while executing a Transact-SQL statement or batch. (Microsoft.SqlServer.ConnectionInfo)

------------------------------

User, group, or role 'NBNUser' already exists in the current database. (Microsoft SQL Server, Error: 15023)

For help, click: http://go.microsoft.com/fwlink?ProdName … nkId=20476

Craig Slawson
Staffordshire Ecological Record

6

Re: Recorder Login

Hi

The answer may be that NBNUser has been disrupted (see para 7 at http://www.recorder6.info/page37.html If you have just switch SQL Version this isn't normally necessay, but worth a  try. First run the following in NBNData

EXEC sp_change_users_login 'Update_One', 'NBNUser', 'NBNUser

If this doesn't run or has no effect  try the following full NBNUser setup  run in Master


IF NOT EXISTS(SELECT * FROM Master.dbo.SysLogins WHERE Name='NBNUser')
          CREATE LOGIN NBNUser WITH PASSWORD='NBNPassword', CHECK_POLICY=OFF

EXEC sp_addsrvrolemember 'NBNUser', 'dbCreator'

EXEC sp_addsrvrolemember 'NBNUser', 'diskAdmin'

USE NBNData

IF NOT EXISTS(SELECT * FROM SysUsers WHERE Name='NBNUser')
    CREATE USER [NBNUser] FOR LOGIN [NBNUser] WITH DEFAULT_SCHEMA=[NBNUser]
GO

EXEC sp_addrolemember 'db_backupoperator', 'NBNUser'
EXEC sp_addrolemember 'db_datareader', 'NBNUser'
EXEC sp_addrolemember 'db_datawriter', 'NBNUser'
EXEC sp_addrolemember 'db_ddladmin', 'NBNUser'
EXEC sp_addrolemember 'db_owner', 'NBNUser'

EXEC sp_change_users_login 'Update_One', 'NBNUser', 'NBNUser

Mike Weideli
Littlefield Consultancy - IT Consultants

7

Re: Recorder Login

Hi Mike,

Thanks for all your advice, but I found the problem - the 'incorrect password' was the correct error - when I recreated the NBNUser Login I used the sa password, now I know what the correct password is (should have read the manual DOH!) it is all working again

Craig

Craig Slawson
Staffordshire Ecological Record

8

Re: Recorder Login

Mike,

I've had to move the data again (because we reverted back when the problems arose) and I've found I did need to run your query above to get the system running. (Note, not sure if it is your typing or the forum, but the final quote mark is missing from both your queries)

BTW, is there anywhere in Recorder which states which version of SQL Server it is running, I can't find it?

Craig

Craig Slawson
Staffordshire Ecological Record