Topic: Also problems installing indicia from scratch

I've installed the warehouse version 2.27.0 on a local development server.  I've set up a Damselfly taxon and taxon group according to the tutorial at

My Indicia website iform setup recognises the species list, survey, and warehouse but is unable to load the species list for data entry.  Using the basic data entry indicia form, I only get text box for species but no drop-down list comes up with various Damselfly species (screenshot attached).  I have tried to enter free text in the species field.  I have noticed the text box goes red as I move to the next tab which may indicate it's not happy with my free text.  When I check the warehouse for data, the sample, location and date are recorded but there is no trace of any species data in any of the tables in the warehouse   (Should species data be in the taxa table)?

Is there a basic example dataset, warehouse and recording website that I could download or replicate in order to see how Indicia is meant to be used?  This would give me a stable starting point to build upon.



Re: Also problems installing indicia from scratch

Hi Milo
Have you run the scheduled tasks on the warehuose? If not, there is normally a warning on the home page of the warehouse and you can find the documentation for this at https://indicia-docs.readthedocs.io/en/ … asks.html.

Basically, although the species information may be in the system, it needs to be processed into a form which enables rapid and efficient searching and reporting before it can be used.

Best wishes

John van Breda
Biodiverse IT


Re: Also problems installing indicia from scratch

Hi John

I ran the command

php index.php scheduled_tasks > ~/errmess.txt

which generated a number of fatal error messages (attached as a screenshot).  They look pretty serious  Do I have more installing/configuring to do?


Post's attachments

scheduled_tasks_err.jpg 47.26 kb, file has never been downloaded. 

You don't have the permssions to download the attachments of this post.


Re: Also problems installing indicia from scratch

...um...polite bump...

...any ideas why I am getting these errors?  I just need an error-free example of an Indicia warehouse to get started.  If this is a bug then that is fine as I will leave the "scratch" installation until there is a fix.